Just bought my 1st "M" and need some help..

Things that are of general interest.
coastie1160870
Member
Posts: 12
Joined: Sun Jul 02, 2017 8:09 pm

Re: Just bought my 1st "M" and need some help..

Postby coastie1160870 » Sat Jul 08, 2017 6:57 am

Thanks Skye, all good points.. worked on her last night, was to tired for dinner, went to bed and had the worst night ever.! Was so tired that I snored, the dogs snored, sounded like we left the engine running..L.O.L. Might take it a little bit easier today...!
R.A. & B.S. Campbell
1968, 32 Express w/o F-B.
Twin 225's,
Catawba Island, Port Clinton Ohio
Purchased " C-WAVES " on 07-03-2017

Khacha
New poster
Posts: 3
Joined: Mon Jun 13, 2016 8:47 pm

Re: Just bought my 1st "M" and need some help..

Postby Khacha » Sun Jul 09, 2017 6:09 am

Hey former MK here - once you mess with the 41 UTB's that aluminum boat thing stays in you. I am messing with a 1984 28 Express. Check your through the hull fittings; the seacock flange on my boat was plastic and came apart in my hands when I first started working on this project. Luckily the boat was on the hard or it would have been quite an event as it's about a 2" hole in the bottom of the vessel and I would have been stuck in the engine space plugging it with my shirt until someone wandered out the dock.

coastie1160870
Member
Posts: 12
Joined: Sun Jul 02, 2017 8:09 pm

Re: Just bought my 1st "M" and need some help..

Postby coastie1160870 » Sun Jul 09, 2017 7:45 am

I am already wet, and everything looks good so far.. I am having issues with the waste holding tank, but everything else seems ok.. Thanks..I could use a good MK, L.O.L. My mid-ship is bigger than my hatch.!
R.A. & B.S. Campbell
1968, 32 Express w/o F-B.
Twin 225's,
Catawba Island, Port Clinton Ohio
Purchased " C-WAVES " on 07-03-2017

coastie1160870
Member
Posts: 12
Joined: Sun Jul 02, 2017 8:09 pm

Re: Just bought my 1st "M" and need some help..

Postby coastie1160870 » Thu Aug 10, 2017 1:06 am

UP DATE.. I SPENT THREE NIGHTS IN THE DARK AFTER I INSTALLED THE NEW VHF AND GPS SYSTEM.. I THOUGHT I HAD KNOCKED A WIRE LOOSE, AND I LOOKED AT EVERY POSSIBLE WIRE IN THE BOX.. I LOOKED FOR BAD FUSES, LOOSE CONNECTIONS, CLEANED OUT THE POWER CENTER, ZIP TIED ALL THE LOOSE WIRES, AND I FINALLY GAVE UP, WENT TO THE MARINA MECHANIC AND ASK FOR SOME HELP.. "DAVE" CAME ON BOARD AND CHECKED A COUPLE THINGS, THEN HE CHECKED FOR POWER TO THE SYSTEM.. HE SAID: " I'M SORRY, I CAN'T DO ANYTHING FOR YOU, UNTIL YOU CHARGE THE BATTERIES.. YOU HAVE ONLY 3.2 VOLTS IN YOUR STARBOARD BATTERIES, WHICH BY THE WAY, ARE ALSO YOUR HOUSE BATTERIES.." I WAS NOT REALLY CONVINCED THAT WAS MY PROBLEM, BUT 24 HOURS LATER, I HAD ALL MY POWER BACK, ALL MY LIGHTS WERE WORKING, AND THE ENGINE STARTED RIGHT UP.. SO WHAT DID I LEARN.? DON'T MAKE IT ANY HARDER THAN IT IS... LOOK FOR THE SIMPLE THINGS FIRST... I SHOULD HAVE KNOWN THAT, BUT I COMPLETELY MISSED THE BOAT ON THIS ONE..!!
R.A. & B.S. Campbell
1968, 32 Express w/o F-B.
Twin 225's,
Catawba Island, Port Clinton Ohio
Purchased " C-WAVES " on 07-03-2017

BlueSkye
Tin star
Posts: 51
Joined: Sun Jul 20, 2014 9:38 am

Re: Just bought my 1st "M" and need some help..

Postby BlueSkye » Fri Aug 11, 2017 8:00 am

Sounds like she is in the water. Might be tricky checking the strength of the through hulls. I have a couple of "carrots" aboard now but didn't sued to. What I did have was one of those French rolling pins that taper off at each end. I still have it, but one end is cut off. Still does a great job rolling out the pizza dough.
1971 32ft Express 2x318
Seneca Lake, Erie Canal, Lake Ontario, Rideau